If you have recently upgraded to fedora 25 gnome you have noticed that desktop icons were missing, even after enabling the “icons on desktop” option in gnome tweak tool.

This is because fedora 25 is using wayland display server, desktop icons are only supported on X11.According to a main gnome developer Desktop icons aren’t particular priority for them.

We support nautilus rendering desktop icons as part of Classic mode,but not more. The code in nautilus that does this is using X specific apis. Could it be made to work under Wayland ? Certainly. But it is not
a particular priority for us; the basic assumption is that the same
audience that prefers classic mode probably has conservative tastes
when it comes to the display server as well.

How to enable it ?

  1. Logout  from your current session
  2. Click on the gear icon next to the sign in button
    fedora-25-gnome-desktop-icons
  3. select “Gnome on Xorg” option from the drop down menu
  4. now click sign in.

voila! Desktop icons are back!!

PS: make sure “icons on desktop” option in gnome tweak tool is enabled.

Categories: Tutorials

shyam jos

My name is Shyam Jos, I am a passionate Linux system administrator from Kochi, India. I am a strong advocate of using Linux and Open-Source software.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.