Due to a bug in pulseaudio module A2DP option is not working properly in recent versions of fedora and archlinux.

Follow this tutorial if you have trouble connecting your bluetooth speaker/Headset in A2DP mode on Fedora or arch Linux.

Edit the file


Now comment out the following line

#load-module module-bluetooth-discover

Then save it

Now Edit the file


and after the lines:

if [ x”$SESSION_MANAGER” != x ] ; then
/usr/bin/pactl load-module module-x11-xsmp “display=$DISPLAY session_manager=$SESSION_MANAGER” > /dev/null

add below line

/usr/bin/pactl load-module module-bluetooth-discover

Save the file and restart your system

Now you can easily set A2DP in sound settings.

PS: set selinux to permissive

shyam jos

My name is Shyam Jos, I am a passionate Linux system administrator from Kochi, India. I am a strong advocate of using Linux and Open-Source software.


Eric · July 1, 2017 at 12:47 AM

Hey – thanks! This worked on my Acer laptop with Fedora 25 and a Bluedio headset.

    shyam jos · July 2, 2017 at 2:19 PM

    Thanks ! Glad it worked for you

Fajar · August 4, 2017 at 8:14 AM

Thanks, work as charm on my Samsung NP900X3C with Fedora 26

    shyam jos · August 4, 2017 at 8:42 AM

    Hi Fajar, Glad it worked for you

sabata · April 19, 2018 at 12:23 AM

Finally got it to work with this workaround. Was looking in all the wrong places… Thanks a ton for this!!!

Programming Guy · July 5, 2018 at 5:11 PM

Thank you !!! Works on Debian 9 (stretch) as well.

lihongkun · September 2, 2018 at 12:29 PM

fixed my problem!!! no more gitches

Christian Sanchez · January 4, 2019 at 9:12 AM

Thank you for this post, it worked and i have my good sound back, thank you bro

Lucas Vinícius da Rosa · July 8, 2019 at 3:58 PM

Thank you so much for your effective solution ;D
It has worked on my Kali Linux 2019.2 box:

$ uname -a
4.19.0-kali5-amd64 #1 SMP Debian 4.19.37-2kali1 (2019-05-15) x86_64 GNU/Linux

Karol · December 7, 2019 at 1:33 AM

It’s almost 2020 and the problem still remains. Thank you, that worked! 🙂

Pirmin · May 9, 2020 at 12:45 PM

Thanks, this helped me to get my new headphones working with Ubuntu 18.04.

$ uname -a
Linux Ragete 5.3.0-51-generic #44~18.04.2-Ubuntu SMP Thu Apr 23 14:27:18 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

» Fixing the A2DP Bluetooth profile issue in Fedora 27 Ken Savich · April 21, 2018 at 6:45 AM

[…] via Fix- Bluetooth speaker A2DP issue in Fedora and archlinux […]

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.