Fix error:1407742E:SSL in ubuntu

Published by shyam jos on

Recently I have got an error message when I tried to update rvm in an old ubuntu 12.04 server,

rvm curl: (35) error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
OpenSSL: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
the

After some digging on google, I have found that this error is due to using the old version of OpenSSL libraries.

How to fix error:1407742E:SSL  ?

To fix this error in ubuntu just update the OpenSSL and related libraries.

sudo apt-get update
sudo apt-get install libssl-dev curl wget openssl

Categories: Tutorials

shyam jos

My name is Shyam Jos, I am a passionate Linux system administrator from Kochi, India. I am a strong advocate of using Linux and Open-Source software.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.