Raspbian jessie repository is using a bit outdated version of kodi (version 15 and latest stable is kodi 17 krypton),  By using the pipplware repository you will receive latest updates of kodi faster than the official raspbian repository .To install the latest version of kodi (kodi 17.3) on your raspberry pi follow below steps.

 

Note 1: This tutorial is for Raspbian jessie,  If you are running latest Raspbian Stretch Follow this guide.
Note 2: Latest version in pplware jessie repo is 17.3 (kodi latest stable is 17.4)

Add the pipplware repository  to  /etc/apt/sources.list

sudo nano /etc/apt/sources.list

add below line to /etc/apt/sources.list

deb http://pipplware.pplware.pt/pipplware/dists/jessie/main/binary /

Add the keys

wget -O - http://pipplware.pplware.pt/pipplware/key.asc | sudo apt-key add -

Now update the sources and Upgrade your Rpi

sudo apt-get update && sudo apt-get dist-upgrade

Now install Kodi

sudo apt-get install kodi

install Kodi PVR addons (optional)

sudo apt-get install kodi-pvr*

Set permissions for kodi

sudo addgroup --system input

Create new file

sudo nano /etc/udev/rules.d/99-input.rules

Now add the below lines to above file

SUBSYSTEM==input, GROUP=input, MODE=0660
KERNEL==tty[0-9]*, GROUP=tty, MODE=0660

Create new file

sudo nano /etc/udev/rules.d/10-permissions.rules

Now add the below lines to above file

#input
KERNEL=="mouse|mice|event", MODE="0660", GROUP="input"
KERNEL=="ts[0-9]|uinput", MODE="0660", GROUP="input"
KERNEL==js[0-9]
, MODE=0660, GROUP=input
#tty
KERNEL==tty[0-9]*, MODE=0666
#vchiq
SUBSYSTEM==vchiq, GROUP=video, MODE=0660

Now run the following commands

Note:Replace ‘pi’ with your username (in most cases pi is the default user in raspbian,You can use the command ‘whoami’ to get your username)

sudo usermod -a -G audio pi
sudo usermod -a -G video pi
sudo usermod -a -G input pi
sudo usermod -a -G dialout pi
sudo usermod -a -G plugdev pi
sudo usermod -a -G tty pi

How to enable shutdown and reboot option in kodi power menu

To add shutdown or reboot option you need Make Sure policykit-1  package is installed then create a new policy kit file.
sudo nano /etc/polkit-1/localauthority/50-local.d/all_users_shutdown_reboot.pkla
Now add below contents to the file

[Allow all users to shutdown and reboot]
Identity=unix-user:*
Action=org.freedesktop.login1.*;org.freedesktop.upower.*;org.freedesktop.consolekit.system.*
ResultActive=yes
ResultAny=yes
ResultInactive=yes 

To start kodi automatically with boot  (raspbian boots directly to kodi)
Run below command to add Kodi upstart script

 sudo wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw;sudo chmod +x /etc/init.d/kodi

Then enable upstart script by running below command

sudo systemctl enable kodi

Voila! now you have successfully installed kodi on your raspberry pi

PS: Make Sure you have gpu memory of >=160MB to play Full HD videos. (use raspi-config command to increase  it)

 

 

How to install latest version kodi 17 krypton on Raspbian jessie [Rpi2,Rpi3]
Tagged on:     

128 thoughts on “How to install latest version kodi 17 krypton on Raspbian jessie [Rpi2,Rpi3]

  • October 29, 2016 at 6:58 PM
    Permalink

    When you tell ‘Add the keys’, what are you speaking about? How I add the keys?
    Thanks a lot.

    Reply
  • December 27, 2016 at 5:42 PM
    Permalink

    after running sudo apt-get update i get:
    E: Type ‘wget’ is not known on line 3 in source list /etc/apt/sources.list.d/pipplware_jessie.list
    E: The list of sources could not be read

    Reply
  • December 29, 2016 at 11:51 PM
    Permalink

    After entering all the entries on this page. I stall ended up with Kodi 15

    Reply
    • December 30, 2016 at 8:16 AM
      Permalink

      Try
      sudo apt-get purge kodi && sudo apt-get update && sudo apt-get install kodi

      Reply
  • February 5, 2017 at 7:47 PM
    Permalink

    After following all your steps and trying to run Kodi, nothing happens.
    (note: even with the Kodi 15, nothing happens when trying to run it)

    Any ideas why this is?

    Reply
    • February 6, 2017 at 9:48 PM
      Permalink

      Did you tried starting kodi from terminal by typing : kodi-standalone

      Reply
      • May 14, 2017 at 12:17 PM
        Permalink

        I have the same problem and I tried to run using the kodi-standalone

        Reply
        • May 14, 2017 at 1:02 PM
          Permalink

          I think it is because of the connection through VNC.

          Reply
          • August 2, 2017 at 11:37 AM
            Permalink

            Hi,
            great instruction. Did somebody else observe this phenomenon too? When I start kodi nothing happens, but I am also connected to the Rpi by vnc.

            Any solutions? I do not have a monitor for the Rpi available.

            Holger

  • February 9, 2017 at 7:33 PM
    Permalink

    Wow.. what a perfect instruction !!! I followed each steps carefully and i got working Kodi 17, Krypton working in first trial.

    My initial thoughts on this.
    1. I had to reboot 3 times during this process. I mean screen froze and reboot was the only option mainly during Kodi configuration.
    2. I think its not ready for use here on Raspbian. I mean, i got it working, but its slow. very slow. Many menus of Plugin shows up as dots(no names). I am not sure what exact version got installed, It just feels useless at times.

    I hope this helps. I would wait to get on this one.

    My question is, how can I uninstall it and go back to older version of Kodi now 🙁

    Reply
    • February 9, 2017 at 10:56 PM
      Permalink

      Just remove it with apt-get remove kodi and remove “http://pipplware.pplware.pt/pipplware/dists/jessie/main/binary /” from sources.list then apt-get update, thats it 🙂

      Reply
  • February 16, 2017 at 10:50 PM
    Permalink

    Can you please explain why you need to add all those permissions at the end.
    I just installed KODI and increased memory split to 128 and it seems to work fine.
    Just curious as to why you added all those permissions.

    Thanks for the post.
    YV

    Reply
    • February 17, 2017 at 8:09 AM
      Permalink

      To provide access to system ports (usb,serial) and devices. Otherwise usb keyboard/mouse may not work properly

      Reply
      • February 17, 2017 at 6:43 PM
        Permalink

        Thanks for the reply.

        Reply
        • February 24, 2017 at 11:36 AM
          Permalink

          Welcome 🙂

          Reply
  • February 23, 2017 at 3:45 AM
    Permalink

    terminate called after throwing an instance of ‘/dbiplus:DbErrors’
    Aborted (core dumped)

    Oops! any ideas what I messed up. previously had v 16 running

    Reply
    • February 23, 2017 at 8:57 AM
      Permalink

      Can you share the full error log ?

      Try removing libcec and reinstall it

      Reply
      • April 7, 2017 at 2:16 AM
        Permalink

        I tried doing this but I’m still having the same problem… Here is an error dump
        ############## Kodi CRASH LOG ###############

        ################ SYSTEM INFO ################
        Date: Thu Apr 6 13:09:20 PDT 2017
        Kodi Options:
        Arch: armv7l
        Kernel: Linux 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017
        Release: Raspbian GNU/Linux 8 (jessie)
        ############## END SYSTEM INFO ##############

        ############### STACK TRACE #################
        =====> Core file: /home/pi/core (2017-04-06 13:09:18.808544359 -0700)
        =========================================
        [New LWP 4230]
        [New LWP 4231]
        [New LWP 4252]
        [Thread debugging using libthread_db enabled]
        Using host libthread_db library “/lib/arm-linux-gnueabihf/libthread_db.so.1”.
        Core was generated by `/usr/lib/arm-linux-gnueabihf/kodi/kodi.bin –lircdev /var/run/lirc/lircd’.
        Program terminated with signal SIGABRT, Aborted.
        #0 0x755a3f70 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56

        Thread 3 (Thread 0x736ff3b0 (LWP 4252)):
        #0 0x7563db80 in poll () at ../sysdeps/unix/syscall-template.S:81
        #1 0x00565e88 in CFDEventMonitor::Process() ()
        #2 0x008548e8 in CThread::Action() ()
        #3 0x00854afc in CThread::staticThread(void*) ()
        #4 0x76f4fe90 in start_thread (arg=0x736ff3b0) at pthread_create.c:311
        #5 0x75647598 in ?? () at ../ports/sysdeps/unix/sysv/linux/arm/nptl/../clone.S:92 from /lib/arm-linux-gnueabihf/libc.so.6
        Backtrace stopped: previous frame identical to this frame (corrupt stack?)

        Thread 2 (Thread 0x740023b0 (LWP 4231)):
        #0 0x76f547a4 in __pthread_cond_wait (cond=0x30b36e8, mutex=0x30b3720) at pthread_cond_wait.c:187
        #1 0x00f7e59c in ANNOUNCEMENT::CAnnouncementManager::Process() ()
        #2 0x008548e8 in CThread::Action() ()
        #3 0x00854afc in CThread::staticThread(void*) ()
        #4 0x76f4fe90 in start_thread (arg=0x740023b0) at pthread_create.c:311
        #5 0x75647598 in ?? () at ../ports/sysdeps/unix/sysv/linux/arm/nptl/../clone.S:92 from /lib/arm-linux-gnueabihf/libc.so.6
        Backtrace stopped: previous frame identical to this frame (corrupt stack?)

        Thread 1 (Thread 0x74004000 (LWP 4230)):
        #0 0x755a3f70 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
        #1 0x755a5324 in __GI_abort () at abort.c:89
        #2 0x75731b5c in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
        #3 0x7572f9a0 in ?? () from /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
        Backtrace stopped: previous frame identical to this frame (corrupt stack?)
        ############# END STACK TRACE ###############

        ################# LOG FILE ##################

        13:09:16.382 T:1946173440 NOTICE: special://profile/ is mapped to: special://masterprofile/
        13:09:16.382 T:1946173440 NOTICE: ———————————————————————–
        13:09:16.382 T:1946173440 NOTICE: Starting Kodi (17.1-RC2 Git:20170312-b2013fd-dirty). Platform: Linux ARM 32-bit
        13:09:16.383 T:1946173440 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
        13:09:16.383 T:1946173440 NOTICE: Kodi compiled Mar 12 2017 by GCC 4.9.2 for Linux ARM 32-bit version 3.16.7 (200711)
        13:09:16.383 T:1946173440 NOTICE: Running on Raspbian GNU/Linux 8 (jessie), kernel: Linux ARM 32-bit version 4.4.50-v7+
        13:09:16.393 T:1946173440 NOTICE: FFmpeg version/source: ffmpeg-3.1-kodi
        13:09:16.393 T:1946173440 NOTICE: Host CPU: ARMv7 Processor rev 4 (v7l), 4 cores available
        13:09:16.393 T:1946173440 NOTICE: ARM Features: Neon disabled
        13:09:16.393 T:1946173440 NOTICE: special://xbmc/ is mapped to: /usr/share/kodi
        13:09:16.393 T:1946173440 NOTICE: special://xbmcbin/ is mapped to: /usr/lib/arm-linux-gnueabihf/kodi
        13:09:16.393 T:1946173440 NOTICE: special://xbmcbinaddons/ is mapped to: /usr/lib/arm-linux-gnueabihf/kodi/addons
        13:09:16.393 T:1946173440 NOTICE: special://masterprofile/ is mapped to: /home/pi/.kodi/userdata
        13:09:16.393 T:1946173440 NOTICE: special://envhome/ is mapped to: /home/pi
        13:09:16.394 T:1946173440 NOTICE: special://home/ is mapped to: /home/pi/.kodi
        13:09:16.394 T:1946173440 NOTICE: special://temp/ is mapped to: /home/pi/.kodi/temp
        13:09:16.394 T:1946173440 NOTICE: special://logpath/ is mapped to: /home/pi/.kodi/temp
        13:09:16.394 T:1946173440 NOTICE: The executable running is: /usr/lib/arm-linux-gnueabihf/kodi/kodi.bin
        13:09:16.394 T:1946173440 NOTICE: Local hostname: Overlord
        13:09:16.394 T:1946173440 NOTICE: Log File is located: /home/pi/.kodi/temp//kodi.log
        13:09:16.394 T:1946173440 NOTICE: ———————————————————————–
        13:09:16.947 T:1946173440 ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs – No such property CanSuspend
        13:09:16.949 T:1946173440 ERROR: DBus: Error org.freedesktop.DBus.Error.InvalidArgs – No such property CanHibernate
        13:09:16.966 T:1946173440 NOTICE: load settings…
        13:09:18.266 T:1946173440 NOTICE: Found 2 Lists of Devices
        13:09:18.266 T:1946173440 NOTICE: Enumerated PI devices:
        13:09:18.266 T:1946173440 NOTICE: Device 1
        13:09:18.267 T:1946173440 NOTICE: m_deviceName : HDMI
        13:09:18.267 T:1946173440 NOTICE: m_displayName : HDMI
        13:09:18.267 T:1946173440 NOTICE: m_displayNameExtra:
        13:09:18.267 T:1946173440 NOTICE: m_deviceType : AE_DEVTYPE_HDMI
        13:09:18.267 T:1946173440 NOTICE: m_channels : FL,FR
        13:09:18.267 T:1946173440 NOTICE: m_sampleRates : 8000,11025,16000,22050,24000,32000,44100,48000,88200,96000,176400,192000
        13:09:18.267 T:1946173440 NOTICE: m_dataFormats : AE_FMT_FLOAT,AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S32LE,AE_FMT_S16LE,AE_FMT_FLOATP,AE_FMT_S32NEP,AE_FMT_S16NEP,AE_FMT_RAW
        13:09:18.267 T:1946173440 NOTICE: m_streamTypes : STREAM_TYPE_AC3,STREAM_TYPE_EAC3,STREAM_TYPE_DTSHD_CORE,STREAM_TYPE_DTS_2048,STREAM_TYPE_DTS_1024,STREAM_TYPE_DTS_512
        13:09:18.267 T:1946173440 NOTICE: Device 2
        13:09:18.267 T:1946173440 NOTICE: m_deviceName : Analogue
        13:09:18.267 T:1946173440 NOTICE: m_displayName : Analogue
        13:09:18.267 T:1946173440 NOTICE: m_displayNameExtra:
        13:09:18.267 T:1946173440 NOTICE: m_deviceType : AE_DEVTYPE_PCM
        13:09:18.267 T:1946173440 NOTICE: m_channels : FL,FR
        13:09:18.267 T:1946173440 NOTICE: m_sampleRates : 48000
        13:09:18.267 T:1946173440 NOTICE: m_dataFormats : AE_FMT_FLOAT,AE_FMT_S32LE,AE_FMT_S16LE,AE_FMT_FLOATP,AE_FMT_S32NEP,AE_FMT_S16NEP
        13:09:18.268 T:1946173440 NOTICE: m_streamTypes : No passthrough capabilities
        13:09:18.268 T:1946173440 NOTICE: Device 3
        13:09:18.268 T:1946173440 NOTICE: m_deviceName : Both
        13:09:18.268 T:1946173440 NOTICE: m_displayName : HDMI and Analogue
        13:09:18.268 T:1946173440 NOTICE: m_displayNameExtra:
        13:09:18.268 T:1946173440 NOTICE: m_deviceType : AE_DEVTYPE_PCM
        13:09:18.268 T:1946173440 NOTICE: m_channels : FL,FR
        13:09:18.269 T:1946173440 NOTICE: m_sampleRates : 48000
        13:09:18.269 T:1946173440 NOTICE: m_dataFormats : AE_FMT_FLOAT,AE_FMT_S32LE,AE_FMT_S16LE,AE_FMT_FLOATP,AE_FMT_S32NEP,AE_FMT_S16NEP
        13:09:18.269 T:1946173440 NOTICE: m_streamTypes : No passthrough capabilities
        13:09:18.269 T:1946173440 NOTICE: Enumerated ALSA devices:
        13:09:18.269 T:1946173440 NOTICE: Device 1
        13:09:18.269 T:1946173440 NOTICE: m_deviceName : default
        13:09:18.269 T:1946173440 NOTICE: m_displayName : Playback/recording through the PulseAudio sound server
        13:09:18.269 T:1946173440 NOTICE: m_displayNameExtra:
        13:09:18.269 T:1946173440 NOTICE: m_deviceType : AE_DEVTYPE_PCM
        13:09:18.269 T:1946173440 NOTICE: m_channels : FL,FR,BL,BR,FC,LFE,SL,SR,UNKNOWN1,UNKNOWN2,UNKNOWN3,UNKNOWN4,UNKNOWN5,UNKNOWN6,UNKNOWN7,UNKNOWN8
        13:09:18.269 T:1946173440 NOTICE: m_sampleRates : 5512,8000,11025,16000,22050,32000,44100,48000,64000,88200,96000,176400,192000
        13:09:18.269 T:1946173440 NOTICE: m_dataFormats : AE_FMT_FLOAT,AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S16LE,AE_FMT_S16BE,AE_FMT_U8
        13:09:18.269 T:1946173440 NOTICE: m_streamTypes : No passthrough capabilities
        13:09:18.269 T:1946173440 NOTICE: Device 2
        13:09:18.270 T:1946173440 NOTICE: m_deviceName : pulse
        13:09:18.270 T:1946173440 NOTICE: m_displayName : PulseAudio Sound Server
        13:09:18.270 T:1946173440 NOTICE: m_displayNameExtra:
        13:09:18.270 T:1946173440 NOTICE: m_deviceType : AE_DEVTYPE_PCM
        13:09:18.270 T:1946173440 NOTICE: m_channels : FL,FR,BL,BR,FC,LFE,SL,SR,UNKNOWN1,UNKNOWN2,UNKNOWN3,UNKNOWN4,UNKNOWN5,UNKNOWN6,UNKNOWN7,UNKNOWN8
        13:09:18.270 T:1946173440 NOTICE: m_sampleRates : 5512,8000,11025,16000,22050,32000,44100,48000,64000,88200,96000,176400,192000
        13:09:18.270 T:1946173440 NOTICE: m_dataFormats : AE_FMT_FLOAT,AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S16LE,AE_FMT_S16BE,AE_FMT_U8
        13:09:18.270 T:1946173440 NOTICE: m_streamTypes : No passthrough capabilities
        13:09:18.350 T:1946173440 NOTICE: Loaded settings file from special://xbmc/system/advancedsettings.xml
        13:09:18.350 T:1946173440 NOTICE: Contents of special://xbmc/system/advancedsettings.xml are…

        720
        540

        750

        30

        31457280

        13:09:18.353 T:1946173440 NOTICE: No settings file to load (special://masterprofile/advancedsettings.xml)
        13:09:18.353 T:1946173440 NOTICE: Default Video Player: VideoPlayer
        13:09:18.353 T:1946173440 NOTICE: Default Audio Player: paplayer
        13:09:18.353 T:1946173440 NOTICE: Disabled debug logging due to GUI setting. Level 0.
        13:09:18.353 T:1946173440 NOTICE: Log level changed to “LOG_LEVEL_NORMAL”
        13:09:18.367 T:1946173440 NOTICE: CMediaSourceSettings: loading media sources from special://masterprofile/sources.xml
        13:09:18.376 T:1946173440 NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
        13:09:18.381 T:1946173440 NOTICE: Loaded playercorefactory configuration
        13:09:18.382 T:1946173440 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
        13:09:18.382 T:1946173440 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
        13:09:18.700 T:1946173440 ERROR: SQL: [Addons27.db] SQL error or missing database
        Query: SELECT idVersion FROM version

        ############### END LOG FILE ################

        ############ END Kodi CRASH LOG #############

        I do hope you can help because this is my only entertainment after work. BTW, I did upgrade from Kodi 16. Is there anyway I can install Kodi 16 ?

        Reply
        • April 7, 2017 at 8:16 AM
          Permalink

          stop Kodi, and delete the existing Addons27.db file. Kodi will build a new one when it’s restarted.

          Reply
          • April 8, 2017 at 12:50 AM
            Permalink

            Thank you for the quick reply… Sorry but can you please do a step by step instruction? Im a noob at this. In the meantime, i’ll try to figure this out. Good day buddy!

          • April 8, 2017 at 7:08 AM
            Permalink

            inside ~/.kodi/userdata/Database

          • April 8, 2017 at 1:29 AM
            Permalink

            ok.. I found where it is. For those having the same problem, you can find the Addons27.db file in your: “~/.kodi/userdata/Database” directory. I do hope this helps somebody.

            UPDATE:
            After deleting the Addons27.db file, Kodi did fired up once again and hopefully, there wouldnt be anymore problems. Thanks shyam jos for the help buddy.

          • April 8, 2017 at 7:08 AM
            Permalink

            Glad that it worked for you 🙂

  • February 23, 2017 at 3:18 PM
    Permalink

    Thank you for instruction. I installed Kodi 17 on my Raspbian PI 3, but I can not to find Simple PVR client for TV. Give me advice on what to do? (In addition I do not have a client PVR folder.)

    Reply
    • February 24, 2017 at 12:59 PM
      Permalink

      Post Updated 🙂

      Reply
      • September 18, 2017 at 8:15 PM
        Permalink

        apt-get install kodi-pvr* fails with a conflict:

        root@RaspberryPi-Media:~# apt-get install kodi-pvr*
        Reading package lists… Done
        Building dependency tree
        Reading state information… Done
        Note, selecting ‘kodi-pvr-pctv-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-demo-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-mediaportal-tvserver-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-hdhomerun’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-vuplus’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-iptvsimple’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-tvheadend-hts’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-nextpvr’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-dvbviewer’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-mythtv-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-njoy-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-stalker’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-dev’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-stalker-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-hts-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-vbox’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-vdr-vnsi’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-hdhomerun-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-dvblink-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-vdr-vnsi-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-vbox-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-argustv’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-dvbviewer-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-wmc’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-njoy’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-filmon’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-dvblink’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-nextpvr-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-hts’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-demo’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-mediaportal-tvserver’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-iptvsimple-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-argustv-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-mythtv’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-filmon-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-pctv’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-vuplus-dbg’ for regex ‘kodi-pvr*’
        Note, selecting ‘kodi-pvr-wmc-dbg’ for regex ‘kodi-pvr*’
        Some packages could not be installed. This may mean that you have
        requested an impossible situation or if you are using the unstable
        distribution that some required packages have not yet been created
        or been moved out of Incoming.
        The following information may help to resolve the situation:

        The following packages have unmet dependencies:
        kodi-pvr-wmc : Conflicts: kodi-pvr-tvheadend-hts
        E: Unable to correct problems, you have held broken packages.

        Did I do something wrong?

        Reply
        • September 18, 2017 at 8:18 PM
          Permalink

          Forgot to add, the rest of it is great! Running Ares ok.

          Reply
  • February 23, 2017 at 4:53 PM
    Permalink

    Resolved. Run the command apt-get install kodi-pvr-iptvsimple.

    Reply
    • February 24, 2017 at 1:00 PM
      Permalink

      Thanks for the inputs 🙂

      Reply
  • February 23, 2017 at 6:50 PM
    Permalink

    Thanks! And how to make kodi start at boot automatically?

    Reply
    • February 24, 2017 at 1:20 PM
      Permalink

      Did you tried this ?: sudo systemctl enable kodi

      Reply
      • February 24, 2017 at 6:46 PM
        Permalink

        Yes I tried and nothing happend 🙁

        Reply
        • February 24, 2017 at 8:27 PM
          Permalink

          seems like upstart script is missing , Try this command: sudo wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw/52f73efdb7a26f30e2038320f84a0173c0c120c0/kodi

          and then sudo systemctl enable kodi

          Reply
          • February 24, 2017 at 8:46 PM
            Permalink

            Thank you for your help shyam jos, but in the meantime I tried the method 5 ( Add a new systemd script) from Kodi Wiki and it work fine, so I dont had the chance to try yours, but I will keep this page in my favorites for the case that I could need it again, since your method is much easier. Thanks again for your help.

          • February 24, 2017 at 9:02 PM
            Permalink

            Welcome 🙂

  • February 24, 2017 at 8:18 AM
    Permalink

    I can not believe! This works… perfectly !!!!!! You are a f*** genius!!

    Reply
    • February 24, 2017 at 11:35 AM
      Permalink

      I am glad it worked for you 🙂

      Reply
  • February 24, 2017 at 5:18 PM
    Permalink

    Thank you very much for your work, I installed kodi in jessie without any problem, but when I put the command To start kodi automatically with boot give me an error:

    sudo systemctl enable kodi
    Failed to execute operation: No such file or directory

    I’m Sorry for my english and thanks.

    Reply
    • February 24, 2017 at 8:28 PM
      Permalink

      Try this command: sudo wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw/52f73efdb7a26f30e2038320f84a0173c0c120c0/kodi

      and then sudo systemctl enable kodi

      Reply
      • February 25, 2017 at 2:11 AM
        Permalink

        Hi Shyam jos , I tried

        https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw/52f73efdb7a26f30e2038320f84a0173c0c120c0/kodi

        Then i put “sudo systemctl enable kodi” and script abort.

        Synchronizing state for kodi.service with sysvinit using update-rc.d…
        Executing /usr/sbin/update-rc.d kodi defaults
        insserv: script kodi is not an executable regular file, skipped!
        Executing /usr/sbin/update-rc.d kodi enable
        update-rc.d: error: no runlevel symlinks to modify, aborting!

        Thanks

        Reply
        • February 25, 2017 at 9:02 PM
          Permalink

          Seems like execute permision is missing , Please try below command
          sudo wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw;chmod +x /etc/init.d/kodi
          and then sudo systemctl enable kodi

          Reply
  • February 24, 2017 at 11:19 PM
    Permalink

    Hi , again.

    When i put :

    wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw/52f73efdb7a26f30e2038320f84a0173c0c120c0/kodi

    All Ok , then i put sudo systemctl enable kodi

    And

    Synchronizing state for kodi.service with sysvinit using update-rc.d…
    Executing /usr/sbin/update-rc.d kodi defaults
    insserv: script kodi is not an executable regular file, skipped!
    Executing /usr/sbin/update-rc.d kodi enable
    update-rc.d: error: no runlevel symlinks to modify, aborting!

    Reply
    • February 25, 2017 at 9:02 PM
      Permalink

      Seems like execute permision is missing , Please try below command
      sudo wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw;chmod +x /etc/init.d/kodi

      and then sudo systemctl enable kodi

      Reply
      • February 26, 2017 at 4:11 AM
        Permalink

        when i run this code , download the script but Can not change script permissions.

        sudo wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw;chmod +x /etc/init.d/kodi

        –2017-02-25 23:36:59– https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw
        Resolviendo gist.githubusercontent.com (gist.githubusercontent.com)… 151.101.132.133
        Conectando con gist.githubusercontent.com (gist.githubusercontent.com)[151.101.132.133]:443… conectado.
        Petición HTTP enviada, esperando respuesta… 200 OK
        Longitud: 4533 (4,4K) [text/plain]
        Grabando a: “/etc/init.d/kodi”

        /etc/init.d/kodi 100%[=====================>] 4,43K –.-KB/s en 0s

        2017-02-25 23:36:59 (10,0 MB/s) – “/etc/init.d/kodi” guardado [4533/4533]

        chmod: cambiando los permisos de «/etc/init.d/kodi»: Operación no permitida

        Reply
        • February 26, 2017 at 10:17 AM
          Permalink

          Oh my bad this is because sudo was missing before “chmod +x” , sudo wget -O /etc/init.d/kodi https://gist.githubusercontent.com/shyamjos/60ea61fd8932fd5c868c80543b34f033/raw;sudo chmod +x /etc/init.d/kodi

          Reply
      • February 26, 2017 at 4:28 AM
        Permalink

        I already have the solution, the script has the user as kodi, changing this works.

        ENABLED = 1
        USER = pi

        Thankyou very much.

        Reply
        • February 26, 2017 at 10:21 AM
          Permalink

          Thanks for the inputs 🙂

          Reply
        • February 26, 2017 at 9:56 PM
          Permalink

          You are the best! That was my solution.

          I replaced in the file /etc/init.d/kodi
          ENABLED=0
          USER=kodi
          to
          ENABLED=1
          USER=myname
          and now Kodi is starting automatically!
          Thank you so much.

          Reply
  • February 26, 2017 at 3:27 PM
    Permalink

    Thanks to you Shyam jobs, everything works fine.

    Reply
  • February 28, 2017 at 9:07 AM
    Permalink

    I have made the installation et it work well, thank you! I have a question: i start directly with Kodi. It is just what I wanted. But Some times i want to get also the Raspbian interface. How can I get it back?

    Reply
    • February 28, 2017 at 9:37 AM
      Permalink

      SSH into your RPI and run below command to disable kodi auto start
      sudo systemctl disable kodi
      to enable again
      sudo systemctl enable kodi

      Reply
  • March 12, 2017 at 4:28 PM
    Permalink

    hi

    i followed the instructions, did not see any obvious errors. when i rebooted the system i can see in the services list scrolling through reboot that kodi service is started, but kodi has not started and i am still at the terminal prompt on the screen.

    not sure what the issue could be

    do have these warnings when i disable
    Synchronizing state for kodi.service with sysvinit using update-rc.d…
    Executing /usr/sbin/update-rc.d kodi defaults
    Executing /usr/sbin/update-rc.d kodi disable
    insserv: warning: current start runlevel(s) (empty) of script `kodi’ overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `kodi’ overrides LSB defaults (0 1 6).
    Removed symlink /etc/systemd/system/multi-user.target.wants/kodi.service.

    dont think anything of obvious issue

    Reply
    • March 13, 2017 at 8:34 AM
      Permalink

      sudo systemctl enable kodi
      sudo systemctl start kodi

      and share the output of sudo systemctl status kodi

      Reply
  • March 20, 2017 at 8:51 PM
    Permalink

    Hi, someone know how i can start or configure Kodi as windows, i want to use kodi and other application at the same moment, I can´t minimize the kodi application. I readed in forum set the configuration as windows but i only have the option set the resolution.
    Thanks.

    Reply
  • March 30, 2017 at 6:57 PM
    Permalink

    Hi. After I installed kodi it’s still v.15, do I have to do the steps after the installation for it to work and in some miraculous way it becomes v.17.

    When I updated I got a lot of “404 not found” on some of the packages from pipplware. Can I type it wrong and it still works to update or have I actually written it wrong. Any thoughts?

    //Erik

    Reply
    • March 31, 2017 at 6:15 PM
      Permalink

      kindly check if you are running raspbian jessie on your rpi by running command lsb_release -a

      Reply
  • March 31, 2017 at 4:37 PM
    Permalink

    If i have raspbian wheezy with kodi 14.1 should i uninstall kodi?

    Reply
    • March 31, 2017 at 6:21 PM
      Permalink

      This repo is for raspbian jessie

      Reply
      • April 1, 2017 at 2:30 AM
        Permalink

        So it means i can’t use this repo?

        Reply
        • April 1, 2017 at 3:38 PM
          Permalink

          yes, you can only use it with jessie

          Reply
  • April 2, 2017 at 4:19 AM
    Permalink

    Hi Shyam,

    Dumping core… Any ideas before I uninstall everything and try again?

    Thanks! -Roy

    ############# Kodi CRASH LOG ###############

    ################ SYSTEM INFO ################
    Date: Sat Apr 1 11:39:22 PDT 2017
    Kodi Options:
    Arch: armv6l
    Kernel: Linux 4.4.50+ #970 Mon Feb 20 19:12:50 GMT 2017
    Release: Raspbian GNU/Linux 8 (jessie)
    ############## END SYSTEM INFO ##############

    ############### STACK TRACE #################
    =====> Core file: /home/pi/core (2017-04-01 11:39:20.685184783 -0700)
    =========================================
    [New LWP 1424]
    [New LWP 1425]
    [New LWP 1426]
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library “/lib/arm-linux-gnueabihf/libthread_db.so.1”.
    Core was generated by `/usr/lib/arm-linux-gnueabihf/kodi/kodi.bin –lircdev /var/run/lirc/lircd’.
    Program terminated with signal SIGABRT, Aborted.
    #0 0xb5503f70 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56

    Thread 3 (Thread 0xb35ff3b0 (LWP 1426)):
    #0 0xb559db80 in poll () at ../sysdeps/unix/syscall-template.S:81
    #1 0x00565e88 in CFDEventMonitor::Process() ()
    #2 0x008548e8 in CThread::Action() ()
    #3 0x00854afc in CThread::staticThread(void*) ()
    #4 0xb6eaee90 in start_thread (arg=0xb35ff3b0) at pthread_create.c:311
    #5 0xb55a7598 in ?? () at ../ports/sysdeps/unix/sysv/linux/arm/nptl/../clone.S:92 from /lib/arm-linux-gnueabihf/libc.so.6
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)

    Thread 2 (Thread 0xb3f633b0 (LWP 1425)):
    #0 0xb6eb37a4 in __pthread_cond_wait (cond=0x293c4b8, mutex=0x293c4f0) at pthread_cond_wait.c:187
    #1 0x00f7e59c in ANNOUNCEMENT::CAnnouncementManager::Process() ()
    #2 0x008548e8 in CThread::Action() ()
    #3 0x00854afc in CThread::staticThread(void*) ()
    #4 0xb6eaee90 in start_thread (arg=0xb3f633b0) at pthread_create.c:311
    #5 0xb55a7598 in ?? () at ../ports/sysdeps/unix/sysv/linux/arm/nptl/../clone.S:92 from /lib/arm-linux-gnueabihf/libc.so.6
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)

    Thread 1 (Thread 0xb3f65000 (LWP 1424)):
    #0 0xb5503f70 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
    #1 0xb5505324 in __GI_abort () at abort.c:89
    #2 0xb5690b5c in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
    #3 0xb568e9a0 in ?? () from /usr/lib/arm-linux-gnueabihf/libstdc++.so.6
    Backtrace stopped: previous frame identical to this frame (corrupt stack?)

    Reply
    • April 2, 2017 at 11:04 AM
      Permalink

      Make Sure you have gpu memory of >=160MB to play Full HD videos. (use raspi-config command to increase it).
      Make sure you are running latest version of jessie (apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y)
      Try changing your power adaptor.

      Reply
      • April 3, 2017 at 12:14 AM
        Permalink

        Thanks Shyam!

        I had 180 MB set for the GPU and up’ed it to 256MB. Changed power transformers to a beefier one although I had Kodi working before I made this mods but not with all pvr, etc. Also did another update and 0 files needed to be updated. It still dumps core.

        I ran a

        strace kodi

        it’s complaining:

        stat64(“/usr/local/sbin/grep?, 0xbed66a90) = -1 EN0ENT (No such file or directory)

        Is this for a Raspberry PI 3 only? I didn’t see the board generation requirements listed anywhere. I’ve got a Model B which worked for some SD videos and all the menus worked. I plan to use a Pi3 but I wanted to try and get it working with several dedicated model B’s if possible.

        Reply
        • April 3, 2017 at 1:43 AM
          Permalink

          Update: I removed all kodi pakages and resintalled. Throwing the same error. I guess it’s time to reimage the entire installation and start over.

          Reply
        • April 3, 2017 at 9:26 PM
          Permalink

          I have only tested it in rpi 2 but i think it will work for rpi 3 also

          Reply
          • April 4, 2017 at 12:16 AM
            Permalink

            Thank you Shyam. Great. I ended up reimaaging and it’s not core dumping anymore. I’m having trouble with adding a source in kodi filemanager because it’s complaining about no PVR background processes running. I’m still troubleshooting that.

            Side Note: In your instructions, you give the option to run as a alternate user than pi but the instructions would be clearer if you added a section on how to set up auto-login as the alternate user. Otherwise, it’s probably best to leave it as pi. Or did I miss something?

          • April 4, 2017 at 8:46 AM
            Permalink

            Happy that finally it worked for you , regarding pvr i am not using it so i can’t comment on it, There is an option in raspi-conf to enable auto login but i think it’s for pi user only , for other than pi user you can try this method http://raspberrypi.stackexchange.com/a/43548/49726

  • April 2, 2017 at 10:08 PM
    Permalink

    After sudo apt-get install kodi

    it freezes on the update of the wolfram-engine package. Any idea how to supress the update of wolrfram-engine? It simply does not fiinish its job but hangs up here.

    (Načítá se databáze … nyní je nainstalováno 112493 souborů a adresářů.)
    Připravuje se nahrazení …/wolfram-engine_11.0.1+2017031701_armhf.deb …
    wolfram-eula license has already been accepted
    Rozbaluje se wolfram-engine (11.0.1+2017031701) přes (11.0.1+2017022002) …

    Reply
    • April 2, 2017 at 11:26 PM
      Permalink

      Just simply remove wolfram package using apt (i have already done that on my rpi)

      Reply
  • April 6, 2017 at 10:04 PM
    Permalink

    Hi there. I’m having problems same as steve.. the
    Terminate called after throwing an instance of ‘dbiplus::DbiErrors’ Aborted (core dumped)
    1. Is there a solution for this?
    2. If none, bow to install Kodi 16 instead?
    Thanks for everything

    Reply
  • April 8, 2017 at 6:04 AM
    Permalink

    Nicely done.

    Any examples on how to help Kodi automatically mount USB storage, or troubleshoot why it’s not working out of the box? Goal would be that Kodi can automount from the UI and make it easy to unmount from the UI as well.

    For an NTFS formatted external drive, I’ve installed the ntfs-3g package, and mounting drives manually from CLI works great. How does Kodi need to be configured to use it’s built-in mechanisms to detect drives and mount them?

    Unplugging an unmounted drive results in a pop-up notification in the Kodi UI that a drive with it’s appropriate label was successfully removed, so some eventing is taking place.

    Reply
    • April 8, 2017 at 7:14 AM
      Permalink

      As which user your kodi is running , pi or kodi ?
      Did you forgot to run these commands ? ( plugdev group provides access to usb)

      sudo usermod -a -G audio pi
      sudo usermod -a -G video pi
      sudo usermod -a -G input pi
      sudo usermod -a -G dialout pi
      sudo usermod -a -G plugdev pi
      sudo usermod -a -G tty pi

      Reply
  • April 9, 2017 at 8:37 PM
    Permalink

    Hi Guys!
    When I had the Kodi v16, I was able to use my Bose Soundlink via it’s Bluetooth or using it’s dongle. With Krypton, it’s not working anymore. Any thoughts about this? And YES… I did re install the bluetooth drives and checked the systems settings (which doesnt show my Bose Soundlink anymore)

    Reply
    • April 9, 2017 at 11:07 PM
      Permalink

      I have no idea carl, I have never used bluetooth speakers with kodi 17

      Reply
      • April 10, 2017 at 2:21 AM
        Permalink

        Too bad I never backed up my Kodi 16 so I could do a comparison. Any idea where I can get another copy of Kodi 16?

        Reply
          • April 11, 2017 at 6:16 AM
            Permalink

            Thanks Shyam Jos. Can you tell me how to do this? I’m not really that good with Linux. Just starting.

          • April 11, 2017 at 10:07 PM
            Permalink

            Just download the .deb files from that repo and install it using command dpkg , eg: dpkg -i Kodi_16.deb

  • April 11, 2017 at 2:46 PM
    Permalink

    Thanks, great post!

    However, I run into some trouble on my RPi 2 running jessie. After installing and rebooting I see this in the output of journalctl -xb :

    Apr 11 21:10:19 raspberrypi systemd-udevd[142]: invalid key/value pair in file /etc/udev/rules.d/10-permissions.rules on line 4,starting at character 1 (‘E’)
    Apr 11 21:10:19 raspberrypi systemd-udevd[142]: invalid key/value pair in file /etc/udev/rules.d/10-permissions.rules on line 6,starting at character 1 (‘E’)
    Apr 11 21:10:19 raspberrypi systemd-udevd[142]: invalid key/value pair in file /etc/udev/rules.d/10-permissions.rules on line 8,starting at character 1 (‘U’)
    Apr 11 21:10:19 raspberrypi systemd-udevd[142]: invalid key/value pair in file /etc/udev/rules.d/99-input.rules on line 1,starting at character 1 (‘U’)
    Apr 11 21:10:19 raspberrypi systemd-udevd[142]: invalid key/value pair in file /etc/udev/rules.d/99-input.rules on line 2,starting at character 1 (‘E’)

    Everything works fine, but there seems to be something wrong with this?

    Reply
    • April 11, 2017 at 10:04 PM
      Permalink

      Please share the contents of the files /etc/udev/rules.d/10-permissions.rules and /etc/udev/rules.d/99-input.rules

      Reply
  • April 13, 2017 at 1:52 AM
    Permalink

    i followed the steps above but i can not get kodi running on my raspberry.

    I tried to run kodi with the console command kodi-standalone
    but it says that it cant find kodi-standalone

    how do i know if kodi is installed properly?

    Reply
  • April 13, 2017 at 4:44 AM
    Permalink

    Worked like a charm! Thanks for this. Had to start from a fresh install since I already had Kodi installed.

    Reply
  • April 14, 2017 at 5:56 PM
    Permalink

    Hi,

    Thanks for the kodi upstart script, it works almost fine =)

    My movie database on the NAS are not displayed at the autostart.
    If I close kodi manually without reboot the Pi, my movie database is displayed correctly after the automatic restart.

    Can you delay the autostart until the network is connected?

    Reply
    • April 15, 2017 at 9:21 AM
      Permalink

      you can add something like this start on net-device-up IFACE=eth0 to the upstart script

      Reply
  • April 15, 2017 at 10:43 PM
    Permalink

    Works great first time. You are good, man.
    This set up of Raspbian with KODI is any time preferred over any KODI-centric ones, for me.
    Just wonder if you would expand on the specific hardware requirements for optional KODI-PVR install.
    Thank you in anticipation

    Reply
  • May 15, 2017 at 9:57 AM
    Permalink

    Excellent tutorial. 17.1 is running great on Rpi3.
    One thing, is there any way to get the other power off options besides Exit? When I run kodi-standalone manually I also get ‘Power off system’, ‘Custom shutdown timer’ and Reboot. Not so with the autostart.

    Reply
    • May 15, 2017 at 10:17 PM
      Permalink

      To add shutdown or reboot option you need create new policy kit file.
      sudo nano /etc/polkit-1/localauthority/50-local.d/all_users_shutdown_reboot.pkla
      Now add below contents to the file

      [Allow all users to shutdown and reboot]
      Identity=unix-user:*
      Action=org.freedesktop.login1.*;org.freedesktop.upower.*;org.freedesktop.consolekit.system.*
      ResultActive=yes
      ResultAny=yes
      ResultInactive=yes 
      Reply
  • May 23, 2017 at 10:35 AM
    Permalink

    what we have to do to apply this policy to get restart and shutdown buttons? I create the file and the folders but I dont get the buttons, I must install iptables or selinux??? any ideas? I am using raspbian lite. thank you.

    Reply
  • May 23, 2017 at 1:16 PM
    Permalink

    ok you have to install policykit-1 to make possible the policy

    Reply
    • May 23, 2017 at 10:43 PM
      Permalink

      Thanks for the update Dave

      Reply
  • May 24, 2017 at 6:06 AM
    Permalink

    I am new a and a noob to Linux.
    Had a brand new rpi3 installed with Raspbian (version 4-102017) and upgraded to the latest.
    Want to install Kodi with it and found this blog.
    Noticed this blog was created last Oct.
    Question is should we follow steps published in this blog or is there updated procedure to install Kodi Krypton since it has been turned official.
    Thanks..

    Reply
    • May 24, 2017 at 11:46 AM
      Permalink

      Yes,By using the pipplware repository you will receive latest updates of kodi faster than the official raspbian repository

      Reply
    • August 24, 2017 at 11:14 PM
      Permalink

      Hi Jaycee. It did work for me. I mean just following the steps here. But some people did have problems. Best tip I can give you is to start off with a newly installed OS on your RPi then install Kodi by following the steps here. That way if something goes wrong, you can always start over easy. Then when your done and all is working, build your RPi from there. Have fun!

      Reply
  • June 8, 2017 at 7:22 PM
    Permalink

    Hi and thank you for a great tutorial.

    I have a small issue tho. I cannot install from any repository other than the official Kodi one. Any pointers?

    Thanks!

    Reply
      • June 9, 2017 at 11:18 AM
        Permalink

        So you ar not able to install kodi plugins not ubuntu packages ?

        Then check your DNS settings ,Check contents /etc/resolv.conf file .try switching to the google dns servers (8.8.8.8, 8.8.4.4), Like below
        nameserver 8.8.8.8
        nameserver 8.8.4.4

        Also check all curl related packages are installed ,

        lib32-libcurl-gnutls, libcurl-gnutls python-pycurl curl

        Reply
        • June 11, 2017 at 4:00 AM
          Permalink

          Hi Shyam!
          Thanks for the pointers. I am on a raspberry pi. Added the nameservers and packages, but for the lib32 one. Can’t seem to find it?

          ERROR: CCurlFile::FillBuffer – Failed: SSL connect error(35)
          https://paste.ubuntu.com/24827010/

          Reply
          • June 11, 2017 at 4:35 AM
            Permalink

            For clarification, I AM able to download from the KODI repo.

          • June 11, 2017 at 10:05 AM
            Permalink

            Are you able to run curl manually curl https://google.com:443 ?
            Also check following packages are installed apt-get install python-openssl python-cryptography python-setuptools python-pkg-resources curl python-software-properties

  • June 11, 2017 at 10:24 PM
    Permalink

    Thanks again!

    Yes, seems to work:

    301 Moved
    301 Moved
    The document has moved
    here.

    Installed the packages you referenced, even purged and re-installed Kodi. Still no luck opening reps other than kodi.

    Reply
    • June 12, 2017 at 8:33 AM
      Permalink

      Did you tried upgrading raspbian , also do a dist-upgrade

      Reply
  • June 13, 2017 at 2:09 AM
    Permalink

    Yes I have, multiple times during the last couple of days. Tried to install on a different raspberry pi as well, same error code.

    Thanks

    Reply
    • June 13, 2017 at 8:32 AM
      Permalink

      Thanks for the update

      Reply
      • June 14, 2017 at 7:42 PM
        Permalink

        Seems that was the issue, I tried again today and it installed without a problem. Thank you so much for your help and tutorial Shyam. I really appreciate the effort!!

        Reply
        • June 14, 2017 at 11:42 PM
          Permalink

          Thanks for the comment 🙂

          Reply
  • August 3, 2017 at 4:08 AM
    Permalink

    i am updating the engineering blogspot raspberry pi carpc and had xbmc and then managed to get kodi 15.02 but now thanks to this tutorial i got this working no problem, the sudo apt get update and sudo update distro i ended up having to enter those as 2 seperate comands and also use a get update 1 extra time, now i can get cracking, update to carbon touch skin, try add navit then all done 🙂

    Reply
  • August 5, 2017 at 2:48 AM
    Permalink

    Thank you for the tutorial

    Do you have any insight on how to get the media functions to work from a bluetooth keyboard? On the standard LibreElec each of the functions work out of the box, ie; volume etc.. now only volume up works and I cannot get the volume to turn down.

    Reply
    • August 7, 2017 at 8:55 PM
      Permalink

      Sorry Scott I don’t have any idea

      Reply
  • August 7, 2017 at 3:32 AM
    Permalink

    Hi shyam,

    great article thanks for sharing.
    Installed this on rpi3 and on boot up hear startup sounds but no picture. (1348×768)
    Could it be that res is set to high for my screen?
    How can I rectify.

    Thanks

    Reply
  • August 8, 2017 at 9:51 PM
    Permalink

    This is also working with the stock Kodi from Raspbian, but the script in /etc/init.d/kodi needs to be edited to change the port used by “wget” to 9090. Without this, the service will start but “systemctl stop kodi” will never finish.

    Reply
    • August 8, 2017 at 10:10 PM
      Permalink

      Hi mike ,

      I don’t have any issues with 8080 port , may be you have some other service running on 8080 port , please check with `netstat -plant`

      Reply
  • August 21, 2017 at 2:36 PM
    Permalink

    Hi there,

    Just installed a brand new Rasbian on Rasberry Pi 3 and followed the steps here, but udpdate is failing with error bellow. Anybody can give a hand?

    sudo apt-get install kodi
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kodi : Depends: kodi-bin (>= 2:17.3-1~jessie) but it is not going to be installed
    Depends: kodi-bin (< 2:17.3-1~jessie.1~) but it is not going to be installed
    Recommends: libva-intel-vaapi-driver but it is not installable
    E: Unable to correct problems, you have held broken packages.

    Reply
  • September 9, 2017 at 8:45 PM
    Permalink

    Hi Shyam,

    an amazing thanks for this post and the Tuto.

    I used this version and no issue perfect, just 2 days ago i’ve got a update message saying the last version is out, 17.4
    So i tried to update it via the cmd : apt-get update and apt-get upgrade… but nothing still the same..
    How can we update it ? or only the repository owner can do it?

    Thank you in advance,

    Best regards

    Reply
    • September 10, 2017 at 10:54 AM
      Permalink

      Hi Meidhy,

      Latest version in that repo is 17.3 , Yes the repository owner needs to release it

      Reply
  • Pingback: Install latest version kodi 17.4 on Raspbian stretch [Complete Guide]

  • October 1, 2017 at 1:19 PM
    Permalink

    Hi the init.d download just timesout, any ideas?

    Thanks for the help

    Reply
    • October 2, 2017 at 12:19 PM
      Permalink

      Hi ,

      No issues here

      Reply
  • October 5, 2017 at 4:04 PM
    Permalink

    Hi all,

    Looks like a good tuto but I have got trouble with the 1st step. I am also a beginner.

    sudo nano /etc/apt/sources.list works but the terminal gives me a new screen with GNU nano 2.2.6 and title File: /etc/apt/sources.list
    Content is deb http://mirrordirector.raspbian.org/raspbian jessie main contrib non-free
    plus other writing in blue

    I can’t remove those lines, and from there I don’t see how to add the following line: deb http://pipplware.pplware.pt/pipplware/dists/jessie/main/binary /. I can’t write it but it doesn’t execute.
    Any idea?
    Thanks

    Reply
    • October 6, 2017 at 8:43 AM
      Permalink

      If you are on graphical desktop then you can run this command on terminal sudo leafpad /etc/apt/sources.list

      Reply
    • October 9, 2017 at 10:14 PM
      Permalink

      it’s not a command , you have to insert that string using the text editor

      Reply
  • October 7, 2017 at 4:24 PM
    Permalink

    Hi all,

    at first Thanks for the great Script.
    I have searched a long Time for something like This.

    But i have some Questions.
    I´m also a Newbie with Raspbian and/or Jessie and i used the latest Jessie Pixel and Kodi 17.3 from the official Repo.

    The script works fine for me but if I want to stop Kodi over SSH with Systemctl Stop Kodi, it stops Kodi but it does not go back correctly to pixels.
    I only see some graphic artifacts on the screen, it seems that the pixel screen was not loaded correctly.

    Is there any Way to fix it?
    And if it is, what did i have to do?

    Best Regards from Germany

    Reply
    • October 9, 2017 at 10:20 PM
      Permalink

      Hey Max,

      Did you tried sudo service lightdm restart

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

%d bloggers like this: